
 

2Create A Superstory FAQ 
For the latest version of this document please go to www.2simple.com > support > technical questions 

 

Questions answered in this FAQ 

Q: I am unable to access the teacher options using ctrl+shift+“o” 

Q: How do I change the printer? 

Q: How do I use the Journey and Activity screens? 

Q: There are some aspects of this program which are not explained in the user guide 

Q: How do I use the “adv” animations for objects and pictures? 

Q: How do I use the “Magic AR Paper” template? 

Q: I installed Flash Player from www.adobe.com but I still get a flash-related error message 

Q: When I view the videos using screen res 1024x768, the title bar in the video becomes hidden 

Q: What options are configurable in the xml file? 

Q: Can I add my own background to the Textured screen? 

Q: How do I make the page navigation arrows larger for SEN use? 

Q: When I get to the end of a book can I have a home icon rather than having to click all the way back? 

Q: Can I control page turning using the keyboard (eg. enter key) for switch accessibility? 

Q: Can I get an object to follow a path that doubles back? 

Q: I am not based in the UK and have problems using this program 

Q: Can I use ActionScript to dynamically refer to the current page? 

Q: I set an object to hide on frame 1, but it is still momentarily visible when the story turns to that page 

Q: Can I combine multiple separate stories into a single swf file? 

Q: When editing an object’s timeline, I cannot see bin which allows me to delete actions 

Q: I want the person’s leg to rotate faster 

Q: The text has shrunk and I can't expand it 

Sound 

Q: I click on the “import sound” button when editing an individual object, and all I get is a click sound? 

Q: Can I use lip syncing with an imported sound? 

Q: I record a sound but it plays back crackly 

Speech Bubbles 

Q: Any speech bubbles I add to my story appear non-transparent, within a grey box. 

Q: The speech bubble gets larger when my object gets larger 

Errors 

Q: “Run-time error 13: Type mismatch” when printing 

Q: “Run-time error 68: Device unavailable” 

Q: “Run-time error 339: Component csxImage or one of its dependencies not correctly registered…” 

Q: “Run-time error 372: Failed to load control … your version might be outdated…” 

Q: “Run-time error 380: Invalid property value"  

Q: “Run-time error -2147418113 (8000ffff): Method '~' of object '~' failed” 

Q: “Sorry. This file couldn't be saved here. (Path not found).” when saving 

Q: “Sorry. This file could not be opened. [DoOpenFile] Invalid property value (380)" when opening 

Q: “Sorry. This file could not be opened. [DoOpenFile] File not found (53)" when opening 

Q: “No 2cas2.xml settings file” 

 

 

 

Q: I am unable to access the teacher options using ctrl+shift+“o” 

A: This program does not have teacher options. 

 

Q: How do I change the printer? 

A: When you click print, the current printer shows in grey on the print dialog box. If you click it, it becomes a 

dropdown box and you can change the printer.  (Note that you cannot change the default printer as you 



could with some other 2Simple programs.) 

 

Q: How do I use the Journey and Activity screens? 

A: See the latest version of the User Guide which has been updated: 

http://support.2simpleweb.com/public/docs/userguides/2CASS_UserGuide.pdf  

 

Q: There are some aspects of this program which are not explained in the user guide 

A: The User Guide has been updated and the latest version can be found here: 

http://support.2simpleweb.com/public/docs/userguides/2CASS_UserGuide.pdf  

 

Q: How do I use the “adv” animations for objects and pictures? 

A: This involves adding your own ActionScript code. See the Advanced User Guide here:  

http://support.2simpleweb.com/public/docs/userguides/2CASS_UserGuide_Advanced.pdf  

 

Q: How do I use the “Magic AR Paper” template? 

A: See http://support.2simpleweb.com/public/docs/general/AR.pdf 

 

Q: I installed Flash Player from www.adobe.com but I still get a flash-related error message 

A: See http://support.2simpleweb.com/public/docs/general/Playing_swf_files.pdf 

 

Q: When I view the videos using screen res 1024x768, the title bar in the video becomes hidden 

A: Currently the best way to fix this is as follows: Go to http://support.2simpleweb.com/public/fixes/2CASS/ 

and download the file “video player.exe”. Place it in the videos folder where you have the program installed 

(by default C:\Program Files\2Simple Software\2CASS\videos), overwriting the existing file with the same 

name.  

 

Q: What options are configurable in the xml file? 

The 2cas2.xml file is located in the same place as the main program file, typically C:\Program Files\2Simple 

Software\2CASS. Here is an explanation of the settings you might want to change 

<working path='MYDOCS' /> 

<tempfiles path='usertemp' /> 

<resources path='apppath\resources' /> 

<clipart path='apppath\clipart' /> 

<videos path='apppath\videos' /> 

<objects path='apppath\objects' maxperpage='12' /> 

- Working path sets the default open and save folder. The install setting is “MYDOCS” which maps to 

the My Documents folder of the logged in user. It could be changed, for example, to a mapped 

network drive such as P:\, or a UNC path such as \\ServerName\SharedFolderName. 

- Temp Files sets the folder which is used to store temporary files while the program is running. The 

default is “usertemp” which maps to C:\Documents and Settings\USERNAME\Local 

Settings\Temp\2cas2 (2000 and XP), or  C:\Users\USERNAME\AppData\Local\Temp\2cas2 (Vista 

and Win 7) This folder almost always has write permissions by default even for restricted users, and 

so no further permissions modification is required.  

- Resources, Clipart, Videos, Objects - sets where the program looks for these folders. “apppath” is a 

code which tells the program to look in the same folder in which it finds itself in. This does not 

usually need to be changed, but as with the other path settings, can be hard-coded to any network 

location. 

<objects path='apppath\objects' maxperpage='12' /> 

The second setting above allows you to change the maximum number of objects allowed for each 

page in the story. The default is 12. Allowed range: 3-20 objects. This does not affect some story 

types—eg Journey only ever has 1 object, and Flip match and AR have no objects. 2x2 will allow 3 

less than the maximum set here, per page.  

<pages maxnum='20' /> 

Specify the maximum number of pages allowed per story. Allowed range: 3-24 pages  



<record maxreclength='15' recstopdelayms='500' /> 

Change the maxreclength to allow more or less time for recording sound. 

Recstopdelayms specifies the number of milliseconds the program will wait before it stops 

recording sound, after you have pressed the the stop button. 

<webcam allow='true' /> 

Set this to false to hide the webcam button. 

<ar message='For more information about this feature visit www.2simple.com/ar' /> 

If you don’t want the above message to appear every time you start up the AR screen, set  

<ar message=''> above.  

 

Q: Can I add my own background to the Textured screen? 

A: Go to the location where the program is installed, typically C:\Program Files\2Simple Software\2CASS. Go 

the following subfolder: resources\graphics\textures. Look at the existing files - they come in pairs of image 

files, each with the same name but ending with an “r” or an “l”. This tells the program which image goes on 

the right side of the page and which on the left side. To add your own files, simply add further gif files to 

this folder in the same way. You can use graphics-editing software to flip your image horizontally if you want 

to create mirror images (but you do not have to do this - in fact the right and left image files could be 

completely different). Once you have added these pictures files to the textures folder, they will show up 

automatically when you right-click the page border in the textured screen. The program will resize the gif 

files so that they fit in the page, but beware that this can cause a skewing effect if the picture dimensions 

are different from the page. 

 

Q: How do I make the page navigation arrows larger for SEN use? 

1. Make sure you view the swf file on your full screen area (this can be dependent on the html file if 

you are viewing it from a web page).  

2. You can add your own objects to the picture area and give these “jump to page” actions when you 

click on them. You can make these objects as large as you want. 

3. A technical option could be to use ActionScript to increase the size of the arrows. For example, you 

could set “_root.page1.nextBut._width = 70; _root.page1.nextBut._height = 70;” (see the advanced 

user guide for more information on ActionScript coding). You could also amend the xml file which 

defines the layout of screen to make the arrows larger, and this would affect all the stories of that 

type. All screen layouts are defined by xml files and stored in the \resources\story types\ folder. 

 

Q: When I get to the end of a book can I have a home icon rather than having to click all the way back? 

A: Yes – add an object to the last page and give it a “jump to page 1” action as a click event. 

 

Q: Can I control page turning using the keyboard (eg. enter key) for switch accessibility? 

A: Yes. See the Switch Access section of the General FAQ in www.2simple.com > support. 

 

Q: Can I get an object to follow a path that doubles back? 

A: Yes: 

1. Add a line follow path that goes forward and then goes back 

2.  Edit the object’s timeline and add an adv code block on each frame to stop the rotation - 

this._rotation = 0;  

3.  Flip the object horizontally when it starts moving in the opposite direction by adding an adv code 

block in the relevant frame:  if (this._xscale > 0) {this._xscale *=-1;}  

Setting the xscale to a negative number flips the image horizontally. The IF statement ensures it only 

happens once, since code in the adv block gets executed 30 times. 

 

Q: I am not based in the UK and have problems using this program 

A: Unfortunately this program is not currently supported for Regional Settings other than English (UK) and 

other English variants but do contact us to discuss this further.  

 

Q: Can I use ActionScript to dynamically refer to the current page? 



A: As discussed in the advanced user guide, pages can be referred to using _root.page1, _root.page2 etc. 

Books with pages which turn (Square book, Portrait, Landscape etc) have root.page1R, _root.page2L (right 

and left) etc. To dynamically refer to the current page you can use the variable storing the current page 

number which is named “_root.curPage”.   For example, if you wanted to hide the next page:  

pg=eval(‘_root.page’ + (_root.curPage+1) ); 

pg._visible=false; 

 

Q: I set an object to hide on frame 1, but it is still momentarily visible when the story turns to that page 

A: This issue affects all page-turning templates (for example “square book” but not “simple”). Even if you set 

an object to hide or fade-in on the first timeline frame, the timeline itself only starts running after the page 

has finished being turned, so you see the object momentarily before it gets hidden (this happens even if the 

object is on the first page of the story). If you want your object to be completely hidden from the first frame 

in one of these templates, the only current workaround is to hide the object behind another object, and 

then remove the covering object at a later stage. The covering object cannot be completely white in colour, 

because white is regarded as transparent by the program.  

 

Q: Can I combine multiple separate stories into a single swf file? 

A: There are third-party software packages which provide this functionality (eg search online for “combine 

swf files”). Alternatively, this can be done manually, although technically it is a very advanced option and is 

not intended for general use: This is a guideline of how it could be done manually: 

1. The separate stories need to be the same type of story, eg all created using the “simple” template. 

2. In Windows Explorer, go to each individual saved .2c2 file and rename it to have a .zip extension (to 

view file extensions, you may need to do the following In Windows Explorer: Click Tools > Folder 

Options > View, untick “Hide extensions for known file types” and click APPLY.) 

3. Unzip the files 

4. The text and pictures for each area are stored in separate files, eg “tb0p1.txt” means “text box 0 on 

page 1” and “bg0p1.png” means “background picture 0 on page 1”. Rename the page numbers for 

all text and picture files into the desired sequence, and place them all in a single folder. 

5. Combine the “fileinfo.xml” files for all stories. You should not simply copy and paste the entire 

contents of each file, rather copy the relevant “page” sections. Rename each page’s “num” value, 

and also the “numpages” property at the top. 

6. Rezip the files, and rename the zipped file back to .2c2. 

 

Q: When editing an object’s timeline, I cannot see bin which allows me to delete actions 

A: This happens if you are using a screen resolution of 800x600. The minimum recommended resolution for 

this program is 1024x600. If you nonetheless would like to use the program on 800x600, you can 

workaround the above problem by dragging the timeline window a little to the left (you can also delete an 

action without using the bin as follows: select the action by starting to drag it and then press delete, while 

dragging). 

 

Q: I want the person’s leg to rotate faster 

A: If you add a “person” object to your story (the one with the green legs and arms, indicating that they can 

be animated individually), and add a “leg rotate” action to the object timeline, this will cause the leg to 

rotate when you press play. Adding multiple animations to the same timeline cell will have a cumulative 

effect, so adding 2 leg rotate actions will cause it to rotate twice as fast and twice as far. If you want the leg 

to rotate faster but NOT further, you can achieve this using ActionScript. Please note that this is a very 

advanced option, not suitable for beginners. Open Windows Explorer and go to the folder C:\Program 

Files\2Simple Software\2CASS\objects\humans\front flexi. Open the file “01rt leg acw.as”, for example. This 

is the ActionScript file which describes what animation should happen when you want the right leg to rotate 

anticlockwise. You can open the file using Notepad. The file will show:  

onClipEvent(enterFrame){ _root.ob.p2._rotation-=2;} 

This tells the program that the person’s right leg (named “p2”) needs to have its rotation decreased by 2 

degrees every frame. Since there are 30 frames per second in the program, this code will be executed 30 

times in the space of 1 second, and the leg will rotate a total of 60 degrees. We can make the leg rotate 



faster by changing it, for example, to _root.ob.p2._rotation-=6; The only problem now is that the leg will 

end up rotating 6x30 = 180 degrees. To stop the leg rotating after 60 degrees, we can define a variable in 

the startup code section (right-click the green triangle)  

var leg_rotations:int=0; 

And in the code we can change it to 

onClipEvent(enterFrame){ 

_root. leg_rotations ++; 

if (_root. leg_rotations <10) { _root.ob.p2._rotation-=6;} 

} 

This tells the program to only run the rotation code 10 times, rather than 30. This will cause the leg to 

rotate 60 degrees as it originally would have done, but 3 times faster.  

 

Q: The text has shrunk and I can't expand it 

A: The text boxes automatically resize the text to make sure everything fits. If you continue typing until you 

reach the end of the textbox, any more text added will cause all the text to automatically resize to be 

smaller.  Sometimes a child may add a number of ENTER or SPACE characters extra spaces at the end of a 

sentence. As these are interpreted as text, the program will resize the text downwards.  As the text box is 

'full' you won't be able to resize it back upwards. The solution to this is to remove any enter characters or 

spaces that come after the last word (place the cursor at the end of the text and hold down the 'delete' 

key). Once the extra space is gone you will be able to resize the text again (This can happen in 2Publish+ as 

well.) 

 

Sound 

 

Q: I click on the “import sound” button when editing an individual object, and all I get is a click sound? 

A: You need to drag the import sound icon to the timeline of the object – the import sound dialog box will 

then be displayed. 

 

Q: Can I use lip syncing with an imported sound? 

A: No, this can only be done with a recorded sound. In reality, it is technically possible to use an imported 

sound but it is difficult and thus not recommended. If you’re interested, this is how you would do it: Add an 

object to the page, drag a microphone to the timeline and record a sound. Click ok to finish editing the 

object. Minimise the program and open Windows Explorer. Navigate to the program’s temp folder, usually 

located in C:\Documents and Settings\USERNAME\Local Settings\Temp\2cas2 (2000, XP) or 

C:\Users\USERNAME\AppData\Local\Temp\2cas2 (Vista, Win 7). In this folder you will find a randomly 

named wav file which is the sound recording that has just been completed. You can replace this wav file 

with any other wav file of your choosing and lip syncing should now work with the “imported” file. 

(Note – the Local Settings folder (2000, XP) and the AppData folder (Vista, Win 7) may be hidden by default 

– to view them, select “Tools” from the Windows Explorer title menu (if the title menu is hidden, press the 

“alt” key to display it). Then select Folder options > View. Select "show hidden files, folders and drives") 

 

Q: I record a sound but it plays back crackly 

A: One known solution to this issue is as follows: Open your sound recording settings by double-clicking the 

speaker icon on the bottom right corner of your screen (If you do not see it, click Start > Control Panel > 

Sounds and tick "show volume control on taskbar"). Click Options > Properties and make sure you have 

RECORDING selected (If it is greyed out, you may need to change the mixer device from the dropdown at 

the top). Make sure all the boxes at the bottom are ticked and click OK. You should now see the “Recording 

Control” window. Make sure microphone is selected. If there is an “advanced” button beneath the 

microphone slider, click it. In the new window which appears now, check if you have an option for 

“microphone boost”. If this option is available, tick it. 

 

Speech Bubbles 

 

Q: Any speech bubbles I add to my story appear non-transparent, within a grey box. 



A:  You need to change the colour depth of your display to 32 bit instead of 16 bit. To do this, right click your 

desktop and choose properties > settings, and select “Highest (32 bit)” from the colour quality dropdown, 

then click APPLY. 

 

Q: The speech bubble gets larger when my object gets larger 

A: This issue could occur, for example, if you added a “person” object to your screen and then assign it a 

“walk and grow” animation, as well as a speech bubble. If you go to C:\Program Files\2Simple 

Software\2CASS\objects\humans\front\walk and grow.as , you will see that the animation causes the 

object’s xscale and yscale to increase by 0.4 periodically. To counteract this, add your own ActionScript code 

to the object’s timeline (using the “Adv” action) and type in the following:  

this.speech._xscale-=.4; 

this.speech._yscale-=.4; 

 

 Errors 

 

Q: “Run-time error 13: Type mismatch” when printing 

A: This is a known bug with the current version of the program. It will occur if you open a saved file by 

double-clicking it from outside the program, and then try print it. After this error occurs, the next time you 

open the program make sure you click the NEW button and start a new file, otherwise this error will 

continue to occur even when printing files opened using the OPEN button. The only current workaround for 

this problem is to make sure you open files using the yellow OPEN button within the program; printing will 

then work fine. 

 

Q: “Run-time error 68: Device unavailable” when opening or saving 

A: Check that your My Documents folder exists and is accessible, since this is where 2Create A Superstory 

defaults to when loading and saving. If the working path setting in the 2cas2.xml has been amended, check 

that the new path points to a folder that exists and is accessible (The 2cas2.xml file is usually located in 

C:\Program Files\2Simple Software\2CASS). If the working path setting is still listed as “MYDOCS” and you 

are have a problem with your My Documents folder which you are unable to fix, you can amend the 

working path setting to a different folder on open and save.  

 

Q: “Run-time error 339: Component csxImage or one of its dependencies not correctly registered…” 

A: This error can occur if the program has been installed on a central server location only, and the user tries 

to run the program from a local workstation. It is actually possible to set up the program this way, but you 

need to install the dlls on each local workstation. See 

http://support.2simpleweb.com/public/docs/general/Networks.pdf for a summary of the different ways to 

install our programs on networks.  

 

Q: “Run-time error 372: Failed to load control … your version might be outdated…” 

A: If you already have the latest version installed, try un-installing and re-installing the program, or 

alternatively run the DLL installer for this program which you can download from www.2simple.com > 

support > downloads.  

 

Q: “Run-time error 380: Invalid property value"  

A:  This error is caused by attempting to open a 2c2 file that was created on a different computer, and a 

specific font was used in the document has not been installed on the computer which is trying to open the 

file. Possible solutions:  

(1) Install the desired font on the current computer  

(2) Open the file on the original computer, change to a standard font and resave the file. 

(3) Open the file on the original computer and save as a swf file. The swf file contains everything it 

needs to be viewed, including fonts. You should then be able to view the swf file on other 

computers which do not have the target font installed. 

(4) If you do not have access to the original computer and do not know the font that was used, you can 

manually edit the 2c2 file and change the font that is being used. This is an advanced option and 



would be done as follows:   

a. Rename the file – change the extension from .2c2 to .zip (all 2Create a Superstory files are 

in fact zip files. To view file extensions, you may need to do the following In Windows 

Explorer: Click Tools > Folder Options > View, untick “Hide extensions for known file types” 

and click APPLY.) 

b. Unzip the file. 

c. Edit the fileinfo.xml file using any text editor such as Notepad. Search for “font” and go 

through all font entries, changing to standard fonts such as “arial”.  

d. Save and close the file, rezip the files, and rename the zipped file back to .2c2. 

 

Q: “Run-time error -2147418113 (8000ffff): Method '~' of object '~' failed” 

A: This error can indicate a problem with an imported or recorded sound:  

1. If you import a sound file which is in a format that the program cannot handle. To resolve this, open 

the sound file in Windows Sound Recorder (Start > Programs > Accessories > Entertainment > 

Sound Recorder) and resave it in PCM format, eg click File > Save As, and at the bottom click 

FORMAT and choose PCM and 22.050 kHz, 16 Bit, Stereo. This error has been known to happen 

when importing a sound recording that was made using an Easi-Speak microphone/recorder.  An 

alternative solution in this case is to store the sound files in mp3 format, which these devices are 

able to do, and which works fine within 2Create A Superstory. 

2. If you add a record sound action and then press OK without having recorded anything. To rectify this 

problem, simply delete the record sound action in the timeline for the relevant object. (If you have 

a number of different objects each with its own sound recording, it may be difficult for you to 

identify which is the problematic one. In this case, you are welcome to send the file to us and we 

will fix it for you. Alternatively, if you have some technical background, you can do the following:  

a. Rename the saved file – change the extension from .2c2 to .zip (all 2Create a Superstory 

files are in fact zip files. To view file extensions, you may need to do the following In 

Windows Explorer: Click Tools > Folder Options > View, untick “Hide extensions for known 

file types” and click APPLY.) 

b. Unzip the file. 

c. There are 2 possible problems to look out for in the unzipped folder: (1) 0 KB sound files, 

and (2) wav files referred to in the fileinfo.xml file which do not exist at all in the unzipped 

folder.  (Note that recorded sound files are given random names, eg SZ38QMLD6CXK.wav) 

d. If you find any problematic wav file references, make a note in the fileinfo.xml file about 

which object the sound files refer to. You should be able to work out which page the object 

is on, and what number object it is on the page (eg “n=1”). Rather than make changes 

directly to the xml file (which you can do if you want), it will be easier to re-open the file in 

2Create a Superstory and simply delete the relevant reference to a record sound action. To 

do this within the program, go to the target page and find the relevant object. To view an 

object’s number, click on it once with your mouse and the number will appear in light blue 

on the top right corner of the screen (eg “ob 1” for object number 1).  

 

Q: “Sorry. This file couldn't be saved here. (Path not found).” when saving 

A: The program defaults to the “My Documents” folder when you save and open, so most likely what is 

happening is that it is unable to find your “My Documents” folder. This could happen, for example, if you 

normally use a laptop at a school but you are trying to use the program from home while you are not 

connected to the school network. This could also happen if you have amended the 2cas2.xml file “working 

path” entry to a location which does not exist. (The 2cas2.xml file is located in the same place as the main 

program file, typically C:\Program Files\2Simple Software\2CASS.) The solution is to edit the 2cas2.xml file 

“working path” entry so that it refers to a file location which exists and is accessible.  

 

Q: “Sorry. This file could not be opened. [DoOpenFile] Invalid property value (380)" when opening 

A: see above “Run-time error 380: Invalid property value" when opening 

 

 



Q: “Sorry. This file could not be opened. [DoOpenFile] File not found (53)" when opening 

A: This error has been known to occur in the following situation: install 2Create A Superstory, then install an 

*old* version of 2Animate, then run 2Create A Superstory and try open a saved file. The solution is to 

uninstall the old version of 2Animate, and contact us for a download of the latest version. You may also 

need to uninstall and re-install 2Create A Superstory, or run the 2Create A Superstory DLL installer which 

you can download from www.2simple.com/support . (Technical explanation: 2Animate and 2Create A 

Superstory both install and use dll and ocx files, and some of these files are common to both programs. 

However, 2Animate installs an older version of these files which are incompatible with 2Create A 

Superstory. For more information on dlls, see 

http://support.2simpleweb.com/public/docs/general/General.pdf  ) 

 

Q: “No 2cas2.xml settings file” 

A: This error can occur if the program has been installed on a central server location only, and the user tries 

to run the program from a local workstation. It is actually possible to set up the program this way, but you 

need to install the dlls on each local workstation. See 

http://support.2simpleweb.com/public/docs/general/Networks.pdf for a summary of the different ways to 

install our programs on networks.  
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