
 

2Create A Story FAQ 
For the latest version of this document please go to www.2simple.com > support > technical questions 

 

Questions answered in this FAQ 

Printing problems 

Q: Only half the pages have printed out 

Q: Half the pages print back to front 

Q: How do I change the printer?  

Q: How do I print to A3 size (or any size other than A4)?  

Errors 

Q: “Run-time error 5 - invalid procedure call or argument” 

Q: “Run-time error 75: Path/file access error…” 

Q: “Run-time error ‘339’: Component … or one of its dependencies not correctly registered...” 

Q: “Run-time error ‘339’: Component flash.ocx or one of its dependencies not correctly registered...” 

Q: “Run-time error ‘429’: ActiveX component can’t create object” 

Q: “Run-time error ‘-2147463167 (80005001)’: Error at line 1… Type:UTFDataFormatException…” 

Q: “Run-time error ‘-2147463167 (80005001)’: Error at line 1, column 67. Datatype error: …” 

Q: “Run-time error ‘-2147475198 (80002102)’: Object 'shshpp8bu1' is not shown" 

Q: “Run-time error ‘-2147475454 (80002002)’: Error opening file for reading.…” 

Q: “Run-time error ‘-2147475447 (80002009)’: Error decoding sound….” 

Q: “Run-time error ‘-2147479547 (80001005)’: XML schema file not found” 

Q: "Run-time error '-2147479551 (80001001)’: an unknown error occurred" 

Q: “Sorry. This file couldn’t be saved here.” 

Q: “Sorry. This file couldn’t be opened.”  

General 

Q: I open a file which was saved previously and it just displays a blank screen as if nothing was saved 

Q: I press save but am not able to choose which folder to save to 

Q: When pupils use the program, they start to get each other’s work popping up on their screens 

Q: How do I import pictures?  

Q: When I import a picture, the left and right edges of the screen remain white 

Q: There is no “fill” tool / There is only one size of felt-tip to use 

Q: The program just shows the “splash” window in the middle of the screen, and nothing else happens.  

Q: The length of time for voice recording is too short. 

Q: I save a 2cs file and open it on another computer, but I can’t hear my sound recordings when I play it 

Q: Can I use special characters and symbols in 2Create A Story (eg Chinese, Arabic, Hebrew etc) 

Q: Can I import a 2CAS story into 2Create? 

Q: I open a saved file but only part of the pictures are displayed 

Q: I open a saved file but some of the text has disappeared 

Q: I open a saved file but the pictures are displayed only in the top corner of the screen 

Q: I open and play a file that I created on a different computer, but no recorded sounds get played back 

Q: Is it possible to play a story so that it automatically goes from one page to the next, like a slideshow 

Q: Why does a “powered by ActiveSWF” logo appear on the bottom right, when I press play? 

 

 

Printing problems 

 

Q: Only half the pages have printed out 

A: This may occur on a small number of printers for the original version of this program. This has been fixed 

in the latest version – please contact 2Simple for a copy.  

 

Q: Half the pages print back to front 

A: This may occur on a small number of printers for the original version of this program. This has been fixed 



in the latest version – please contact 2Simple for a copy.  

 

Q: How do I change the printer?  

A: Go to teacher options (ctrl + shift + the letter “o”), select the PRINTING tab, and choose the printer from 

the dropdown. Click OK. 

 

Q: How do I print to A3 size (or any size other than A4)?  

A: You cannot do this directly. One workaround is to print to a PDF Printer (which allows you to save your 

file as a pdf file) and then print that as A3 using one of your real printers. See the “Printing FAQ” for more 

information on using PDF Printers.  

 

Errors 

 

Q: “Run-time error 5 - invalid procedure call or argument” 

A: Go to C:\Program Files\2Simple Software\2Create A Story\Temp Files\ and delete all files within this 

folder. Now try run the program.  

 

Q: “Run-time error 75: Path/file access error…” 

A: You need to give full permissions for all users to the 2Create A Story Temp folder, located by default in 

C:\Program Files\2Simple Software\2Create A Story.  

 

Q: “Run-time error ‘339’: Component … or one of its dependencies not correctly registered: a file is 

missing or invalid” 

A: Unless the component is “flash.ocx” (see below), un-installing and re-installing the program should fix 

this, or alternatively run the DLL installer for this program which you can download from www.2simple.com 

> support > downloads.  

 

Q: “Run-time error ‘339’: Component flash.ocx or one of its dependencies not correctly registered: a file 

is missing or invalid” 

A: Go to www.adobe.com and install Adobe Flash Player. 

 

Q: “Run-time error ‘429’: ActiveX component can’t create object” 

A: Un-installing and re-installing the program should fix this, or alternatively run the DLL installer for this 

program which you can download from www.2simple.com > support > downloads.  Additionally, go to 

www.adobe.com and install Adobe Flash Player. 

 

Q: “Run-time error ‘-2147463167 (80005001)’: Error at line 1, column 1. An exception occurred! 

Type:UTFDataFormatException, Message:invalid byte 1 (?) of a 1-byte sequence.”  

A: This error is caused by using a specific type of apostrophe in the text. The standard double quotes and 

single apostrophe both work fine, however the curly single quotes cause the error. This error would usually 

occur only with text that has been pasted into the text area, since the problematic characters cannot be 

typed directly into the 2CAS text area. 

Fine: "  ' Problematic: ‘  ’ 

 

Q: “Run-time error ‘-2147463167 (80005001)’: Error at line 1, column 67. Datatype error: 

Type:InvalidDatatypeValueException, Message:Value ‘468.75’ does not match regular expression facet 

‘(\+|\-)?\d+(px|tw)?”  

A: This error occurs on some wide-screen resolutions (the number which appears after the word “Value” is 

not always 468.75). We have a version which fixes this problem; you can download it from here: 

http://support.2simpleweb.com/public/fixes/2CAS_1093.zip . Download the zip file, unzip it, and place the 

executable in the program folder (by default C:\Program Files\2Simple Software\2Create A Story), 

overwriting the existing executable.  

 



Q: “Run-time error ‘-2147475198 (80002102)’: Object 'shshpp8bu1' is not shown" 

A: The file you have opened has more pages than the teacher options allows. Go into teacher options 

(ctrl+shift+the letter “o”) and amend this setting. 

 

Q: “Run-time error ‘-2147475454 (80002002)’: Error opening file for reading. Object id: pgSnd1. Filename: 

C:\Program files\2Simple software\2Create A Story\Temp files\\\servershared area\music\audio.mp3” 

A: This error occurs when you try attach a sound file using a UNC path rather than a mapped drive. A UNC 

path is one which begins with “\\”. Please import the sound from a mapped drive to resolve this. 

(Alternatively this would occur if the program itself was running off a UNC path and you tried to use one of 

the existing clipsounds.) 

 

Q: “Run-time error ‘-2147475447 (80002009)’: Error decoding sound. Object id: pgSnd1. File name…” or 

“Run-time error ‘-2147475450 (80002006)’: Object has invalid content. Object id: pgSnd1. File name…”  

A: There are some sound file formats that 2Create A Story cannot handle. To resolve this, open the file in 

Windows Sound Recorder (Start > Programs > Accessories > Entertainment > Sound Recorder) and resave it 

in a different wav format, ie  click File > Save As, and at the bottom click FORMAT and choose PCM and 

22.050 kHz, 16 Bit, Stereo. 

 

Q: “Run-time error ‘-2147479547 (80001005)’: XML schema file not found” 

A: The program is looking for the file named “ActiveSWF.xsd” in the program folder (usually C:\Program 

Files\2Simple Software\2Create A Story) but it cannot find this file. Check in that folder to make sure the file 

is there. If it is not, either manually replace the file or reinstall the program on that computer. 

 

Q: "Run-time error '-2147479551 (80001001)’: an unknown error occurred" 

A: This error is caused by a problematic recorded sound file.  To find which page the problematic sound is 

on, try the following:  

1. Make a copy of the problematic 2cs file and rename the copy – change the extension from .2cs to 

.zip (all 2Create a Story files are in fact zip files. To view file extensions, you may need to do the 

following In Windows Explorer: Click Tools > Folder Options > View, untick “Hide extensions for 

known file types” and click APPLY.) 

2. Unzip the file. 

3. For each page in your story for which you have recorded a sound file, there will be a corresponding 

wav file in the file you have just unzipped. The recording for page 1 will be named backsnd1.wav, 

page 2 will have backsnd2.wav, etc. Look for wav files with size 1KB – these are the problematic 

ones.  

4. Don’t manually delete the problematic wav file from the unzipped folder – it’s enough to simply 

find which page has the problematic file. You can now delete the unzipped folder, and go back into 

2Create A Story and open the original file. Go to the relevant page and click on the speaker icon to 

amend the sounds for that page, then in the menu which pops down, click the “no sound” icon – 

the speaker with a cross through it. This will remove the problematic sound file and your file should 

now play back fine. 

5. You should also be able to re-record a sound on the problematic page now. 

 

Q: “Sorry. This file couldn’t be saved here.” 

A: The 2 main possible solutions to this error are  

(1) Give pupils full permissions to the main program folder, ie C:\Program Files\2Simple 

Software\2Create A Story, or 

(2) Change to “standard dialog boxes” for opening and saving. To do this, open the Teacher Options 

(press ctrl + shift + the letter “o”), go to the General tab and click the button with the 3 dots on the 

bottom right. Now select Standard Dialog Boxes on the bottom left and click OK and OK again. 

(3) More rarely, if the program gives any error when you press the green PLAY button (ie it has trouble 

generating the swf file), then if you try save the program will display “This file couldn’t be saved 

here” – because again the program is not able to generate the swf file, for saving this time. This 

could be due to a number of different reasons, and the error you get from pressing play will 



generally be more informative as to the cause. For example:  

“Run-time error ‘-2147475198 (80002102)’: Object 'shshpp8bu1' is not shown" 

"Run-time error '-2147479551 (80001001)’: an unknown error occurred"  

(see separate questions above for explanations of these errors and their solutions) 

Fixing the root cause of the problem will resolve the save error as well. 

 

Q: “Sorry. This file couldn’t be opened.”  

A: The file is probably a swf file that has been mistakenly named as a 2cs file. This can sometimes happen 

when you use standard dialog boxes, as follows (1) Open or save a 2cs file (2) Press save, and choose to 

“export as swf”. The previous filename has been remembered, including the .2cs extension. If you simply 

click SAVE instead of modifying the filename and removing the 2cs extension, the swf file will be saved with 

a 2cs extension instead of a swf extension. Since 2Create A Story cannot open swf files, the next time you 

try open this file you will get the above error message. The solution is to change the file extension back to 

swf. Beware that this issue can also lead to loss of the original 2cs file. 

 

General 

 

Q: I open a file which was saved previously and it just displays a blank screen as if nothing was saved 

A: One possible cause of this issue is as follows: when you start up 2Create A Story and want to open the 

saved file, make sure you click on the YELLOW FOLDER rather than the BLUE DISK. If you click the blue disk it 

indicates you want to save your work rather than open it. If you click the blue disk and then locate the file 

that you had intended to open and then click “yes”, what will in fact happen is that the program will SAVE 

the blank new file on top of the file that you wanted to open, in effect causing you to lose your work.  

 

Q: I press save but am not able to choose which folder to save to 

A: You currently have SIMPLE save dialogs enabled. To choose STANDARD save and open dialogs, go into the 

teacher options (ctrl + shift + the letter “o”), select the GENERAL tab and click the button on the bottom 

right with 3 dots on it. Select STANDARD dialogs on the bottom left and click OK and OK again. You may 

need to be logged in as administrator for this setting to be remembered. You’ll need to make this change on 

each computer (for more info, see www.2simple.com > support > networks > copying 2Simple settings 

across a network) 

 

Q: When pupils use the program, they start to get each other’s work popping up on their screens 

A: The program has probably been installed on a server only, or installed on a thin client system. The Temp 

folder needs to be configured so that it is unique. See www.2simple.com > support > networks > Installing 

on a server only, or installing on a thin client system. 

 

Q: How do I import pictures?  

A: Go to teacher options (ctrl + shift + the letter “o”), select the TOOLS tab and change from CLASSIC to 

TOOLS in the dropdown box. Click OK. Now right-click on the canvas and click IMPORT. 

 

Q: When I import a picture, the left and right edges of the screen remain white 

A: When importing a picture, some 2Simple programs (for example 2Publish+, 2DIY, 2Create a Superstory) 

provide options to choose which part of the picture to import, so you can choose to import the entire 

picture (“letterbox”), or crop part of it so that it takes up the entire area you are importing into (“crop”).  

This feature is not available on 2Create A Story – when you import a picture, it automatically imports the 

entire picture, and if the proportions of the picture are not the same as the area you are importing into, 

there will be a blank white area on the left and right (or top and bottom, depending on the picture 

proportion). If you want your imported picture to take up the entire picture area in 2Create A Story, you 

need to make sure that your picture proportions match the picture area. The 2Create A Story picture area is 

different depending on what screen resolution you are using, for example:  

Screen res Picture area 

1280x1024 1090x590 

1024x768 834x403 



800x600 610x276 

So if you have a screen resolution of 1024x768, make sure the picture you are importing is 834x403 pixels if 

you want to import into the entire area. Note that any corresponding proportion of 834x403 would also 

work, for example if you halve both the width and the height to 417x202.  

(Most image editing applications provide the ability to view and change picture width and height – eg in 

Microsoft Paint, click Image > Attributes). 

 

Q: There is no “fill” tool / There is only one size of felt-tip to use 

A: Go to teacher options (ctrl + shift + the letter “o”), select the TOOLS tab and change from CLASSIC to 

TOOLS in the dropdown box. Click OK.  

 

Q: The program just shows the “splash” window in the middle of the screen, and nothing else happens.  

A: Un-installing and re-installing the program should fix this, or alternatively run the DLL installer for this 

program which you can download from www.2simple.com > support > downloads.  

 

Q: The length of time for voice recording is too short. 

A: You can change this setting by directly editing the configuration settings file, named "2cas.ini" which is 

located by default in C:\Program Files\2Simple Software\2Create A Story. This is a simple text file which you 

can edit in Notepad. The relevant line is maxRecLength=20 which you can amend to 30, for example, to 

make it 30 seconds. You should make the change to the ini file while 2Create A Story is not running. Once 

you have saved and exited the file, you can copy the ini file to other computers in a number of different 

ways - see www.2simple.com >support > networks > copying 2Simple settings across a network 

 

Q: I save a 2cs file and open it on another computer, but I can’t hear my sound recordings when I play it 

A: This can happen if 2Create A Story was installed to a different location on the 2
nd

 computer. The 2 

workarounds for this problem are 

1. Make sure 2Create A Story is installed in the same location on both pcs. 

2. If you are not intending to edit the 2cs file on the 2
nd 

pc (ie you just want to play it), rather export to 

a swf file and use that on the 2
nd

 machine. The swf file will not have this problem. 

 

Q: Can I use special characters and symbols in 2Create A Story (eg Chinese, Arabic, Hebrew etc) 

A: 2Create A Story and most other 2Simple programs only support characters which are in ANSI character 

encoding. This excludes characters from languages such as Chinese, Arabic and Hebrew. For more 

information, see www.2simple.com > support > technical questions > translations 

 

Q: Can I import a 2CAS story into 2Create? 

A: No, you cannot do this. However in 2Create you can link to external files (such as swf, html, pdf and avi). 

To do this, in the actions window for an object, select the “turn page” tab and by “open file” enter the name 

and path of the file (or browse to it). Remember though that the file linked in this way is not stored in the 

final 2Create swf file that gets created, and also that the path is saved as an absolute (not relative) path so 

you need to make sure the exact full path to the external file is available on the computer on which you 

intend to run the 2Create swf file. Note also that the path can be a web link starting “http://...” 

 

Q: I open a saved file but only part of the pictures are displayed 

Q: I open a saved file but some of the text has disappeared 

Q: I open a saved file but the pictures are displayed only in the top corner of the screen 

A: The saved file was created in a different screen resolution than the one in which it is now being opened. 

Change your screen resolution to be the same as what was used when the file was created, and open the 

file again.  

 

Q: I open and play a file that I created on a different computer, but no recorded sounds get played back 

A: This problem will occur in the following situation: on the machine used to open the file, 2CAS is installed 

in a different location, compared to the machine on which the file was originally created. For example, on 

one machine it could be C:\Program Files\2Simple Software\2Create A Story, and on the other machine it 



could be C:\Program Files\2Simple Software\2Simple Collection\2Create A Story. It’s best if 2CAS is installed 

in the same location on each machine (Note that this problem will not occur if you save the file in swf 

format and then play the swf file back on the other machine.) 

 

Q: Is it possible to play a story so that it automatically goes from one page to the next, like a slideshow 

A: This is not possible as far as we are aware in 2Create A Story. However you can achieve this effect with 

some of our other programs, such as 2Create and 2Create A Superstory (see the user guides for those 

programs for more info). 

 

Q: Why does a “powered by ActiveSWF” logo appear on the bottom right, when I press play? 

A: This logo appears if you have installed a “iSpring Free” on your computer. This is a program developed by 

a company which allows you to convert Powerpoint files to Flash. To stop this logo from appearing when 

you press play, click Start > Control panel > Add/remove programs. Uninstall iSpring Free. You can then go to 

http://www.ispringfree.com/ and download and install the latest version of this program which should not 

have this problem.  
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